Unable to access hr.workstream.is

Incident Report for workstream

Resolved

At 840pm PST, the team discovered an issue post regular release deployment and have reverted changes. As of 856pm PST our services have recovered and all functions are operational
Posted May 27, 2024 - 21:03 PDT

Investigating

We are currently investigating and will provide an update within the next hour.
Posted May 27, 2024 - 20:52 PDT
This incident affected: Hiring and Onboarding.