Workstream Jobs website is unresponsive

Incident Report for workstream

Postmortem

What happened?

Jobs site (applicant/employee facing pages: company pages, careers pages, applications, onboarding steps) went unresponsive between 11:09am ~ 16:40pm UTC.

Impact on Customers

Any URL with the path prefix for jobs and career pages (/j) failed to load and returned a server error message

Why did it happen?

We deployed a new configuration to secure our environments that caused an overlap routing traffic that caused a 404 error in our pages

Who raised the issue?

‌We received an escalation from our customer support team at 13:23pm UTC and started an incident management call to resolve the issue.

Action items

Establish monitoring and detection mechanisms in our routing traffic to page server alerts.

Posted Jun 02, 2023 - 12:24 PDT

Resolved

We have resolved this incident and all jobs and career pages have recovered and will follow up with a post-mortem
Posted Jun 01, 2023 - 09:40 PDT

Update

We have identified the issue with our network routing and implemented a fix which recovered a number of customer sites
Posted Jun 01, 2023 - 09:05 PDT

Investigating

We are investigating an issue with our jobs and career pages that are unresponsive
Posted Jun 01, 2023 - 04:09 PDT
This incident affected: Career Page.