Workstream website experiencing high latency

Incident Report for workstream

Resolved

As of 10:55am PST, we have recovered from this incident and is now resolved, we will be working on a post-mortem to investigate the latency further for root cause and implement suggestions to fix.
Posted Aug 28, 2023 - 12:02 PDT

Monitoring

A fix has been implemented and as of 10:55am PST we are recovering, we will be monitoring.
Posted Aug 28, 2023 - 11:26 PDT

Identified

We have identified the issue that is causing the timeouts in our system that results in the latency of our website. We are currently working on a hot fix. We will update again in 30 mins.
Posted Aug 28, 2023 - 10:36 PDT

Investigating

We are currently investigating this issue, the latency is affecting our website. Our banner informing users is up. We will update again in the next 30 mins.
Posted Aug 28, 2023 - 09:45 PDT
This incident affected: Career Page and Hiring.