resumes download are impact

Incident Report for workstream

Resolved

We have identified the issue and a fix has been deployed. The download functionality is restored.
Posted Apr 18, 2022 - 12:08 PDT

Investigating

We are currently investigating the issue.
Posted Apr 18, 2022 - 09:09 PDT
This incident affected: Hiring.