Dropbox Sign errors affecting Workstream

Incident Report for workstream

Resolved

Dropbox Sign resolved this issue as of 11:54 PST, we have no further customer impact.
Posted Jan 31, 2024 - 15:14 PST

Update

Dropbox sign is currently experiencing degraded performance which affects Workstream's ability to to sign for onboarding, hiring for some customers intermittently.

We are currently investigating.
Posted Jan 31, 2024 - 10:45 PST

Investigating

Dropbox sign is currently experiencing degraded performance which affects Workstream's ability to to sign for onboarding, hiring for some customers intermittently.

We are currently investigating.
Posted Jan 31, 2024 - 09:53 PST
This incident affected: Third Party API (HelloSign / HelloFax HelloSign API).